$re = '/(\/post\/find\/)\d*\/{0}/m';
$str = '/post/find/45
/post/find/4/abb
/post/find/044
/post/find/ab/45
/post/find/34/44
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);