import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/post\\/find\\/)\\d*\\/{0}";
final String string = "/post/find/45\n"
+ "/post/find/4/abb\n"
+ "/post/find/044\n"
+ "/post/find/ab/45\n"
+ "/post/find/34/44\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}