package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/post\/find\/)\d*\/{0}`)
var str = `/post/find/45
/post/find/4/abb
/post/find/044
/post/find/ab/45
/post/find/34/44
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}