#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".car\s{0,5}\(([^]]+)\)"
Local $sString = "Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair" & @CRLF & _
"" & @CRLF & _
"Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")