using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".car\s{0,5}\(([^]]+)\)";
string input = @"Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}