import re
regex = re.compile(r".car\s{0,5}\(([^]]+)\)")
test_str = ("Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair\n\n"
"Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")