#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?://)?(?:www\.)?([^.]+)"
Local $sString = "www.xakep.ru" & @CRLF & _
"http://www.fk3vmxex20vzn4ddp.info/default.html" & @CRLF & _
"https://hxin2wz7bkx9oicndd28y6m6i7n.us/img/" & @CRLF & _
"iccan.org" & @CRLF & _
"0iwb0awri.br/warez/" & @CRLF & _
"http://www.google.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")