package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?://)?(?:www\.)?([^.]+)`)
var str = `www.xakep.ru
http://www.fk3vmxex20vzn4ddp.info/default.html
https://hxin2wz7bkx9oicndd28y6m6i7n.us/img/
iccan.org
0iwb0awri.br/warez/
http://www.google.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}