use strict;
my $str = 'www.xakep.ru
http://www.fk3vmxex20vzn4ddp.info/default.html
https://hxin2wz7bkx9oicndd28y6m6i7n.us/img/
iccan.org
0iwb0awri.br/warez/
http://www.google.com/';
my $regex = qr/^(?:https?://)?(?:www\.)?([^.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}