using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?://)?(?:www\.)?([^.]+)";
string input = @"www.xakep.ru
http://www.fk3vmxex20vzn4ddp.info/default.html
https://hxin2wz7bkx9oicndd28y6m6i7n.us/img/
iccan.org
0iwb0awri.br/warez/
http://www.google.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}