import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?://)?(?:www\\.)?([^.]+)";
final String string = "www.xakep.ru\n"
+ "http://www.fk3vmxex20vzn4ddp.info/default.html\n"
+ "https://hxin2wz7bkx9oicndd28y6m6i7n.us/img/\n"
+ "iccan.org\n"
+ "0iwb0awri.br/warez/\n"
+ "http://www.google.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}