re = /^(?:https?:\/\/)?(?:www\.)?([^.]+)/m
str = 'www.xakep.ru
http://www.fk3vmxex20vzn4ddp.info/default.html
https://hxin2wz7bkx9oicndd28y6m6i7n.us/img/
iccan.org
0iwb0awri.br/warez/
http://www.google.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end