using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s,.\/]\s*)?y+[.\/]?";
string input = @"MMM d, y, h:mm a
d MMM y, HH:mm
y年M月d日 ah:mm
dd.MM.y, HH:mm
y. M. d. a h:mm
d MMM y 'г'., HH:mm
dd MMM y, HH:mm
y/MM/dd H:mm
d. MMM y, HH:mm
dd/MM/y h:mm a
dd.M.y HH:mm
d MMM y HH:mm"" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}