import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s,.\\/]\\s*)?y+[.\\/]?";
final String string = "MMM d, y, h:mm a\n"
+ "d MMM y, HH:mm\n"
+ "y年M月d日 ah:mm\n"
+ "dd.MM.y, HH:mm\n"
+ "y. M. d. a h:mm\n"
+ "d MMM y 'г'., HH:mm\n"
+ "dd MMM y, HH:mm\n"
+ "y/MM/dd H:mm\n"
+ "d. MMM y, HH:mm\n"
+ "dd/MM/y h:mm a\n"
+ "dd.M.y HH:mm\n"
+ "d MMM y HH:mm\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}