package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s,.\/]\s*)?y+[.\/]?`)
var str = `MMM d, y, h:mm a
d MMM y, HH:mm
y年M月d日 ah:mm
dd.MM.y, HH:mm
y. M. d. a h:mm
d MMM y 'г'., HH:mm
dd MMM y, HH:mm
y/MM/dd H:mm
d. MMM y, HH:mm
dd/MM/y h:mm a
dd.M.y HH:mm
d MMM y HH:mm" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}