use strict;
my $str = 'MMM d, y, h:mm a
d MMM y, HH:mm
y年M月d日 ah:mm
dd.MM.y, HH:mm
y. M. d. a h:mm
d MMM y \'г\'., HH:mm
dd MMM y, HH:mm
y/MM/dd H:mm
d. MMM y, HH:mm
dd/MM/y h:mm a
dd.M.y HH:mm
d MMM y HH:mm" ';
my $regex = qr/([\s,.\/]\s*)?y+[.\/]?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}