re = /([\s,.\/]\s*)?y+[.\/]?/m
str = 'MMM d, y, h:mm a
d MMM y, HH:mm
y年M月d日 ah:mm
dd.MM.y, HH:mm
y. M. d. a h:mm
d MMM y \'г\'., HH:mm
dd MMM y, HH:mm
y/MM/dd H:mm
d. MMM y, HH:mm
dd/MM/y h:mm a
dd.M.y HH:mm
d MMM y HH:mm" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end