import Foundation
let pattern = #"([\s,.\/]\s*)?y+[.\/]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MMM d, y, h:mm a
d MMM y, HH:mm
y年M月d日 ah:mm
dd.MM.y, HH:mm
y. M. d. a h:mm
d MMM y 'г'., HH:mm
dd MMM y, HH:mm
y/MM/dd H:mm
d. MMM y, HH:mm
dd/MM/y h:mm a
dd.M.y HH:mm
d MMM y HH:mm"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)