using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w*)([+-=]).*)(\2 \3.*)";
string input = @"a+2da + 2d
x-y=3x - y = 3
a+b-c=da + b - c = d
a_n=a+(n−1)da_n = a + (n - 1)d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}