use strict;
my $str = 'a+2da + 2d
x-y=3x - y = 3
a+b-c=da + b - c = d
a_n=a+(n−1)da_n = a + (n - 1)d';
my $regex = qr/((\w*)([+-=]).*)(\2 \3.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}