$re = '/((\w*)([+-=]).*)(\2 \3.*)/m';
$str = 'a+2da + 2d
x-y=3x - y = 3
a+b-c=da + b - c = d
a_n=a+(n−1)da_n = a + (n - 1)d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);