import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\w*)([+-=]).*)(\\2 \\3.*)";
final String string = "a+2da + 2d\n"
+ "x-y=3x - y = 3\n"
+ "a+b-c=da + b - c = d\n"
+ "a_n=a+(n−1)da_n = a + (n - 1)d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}