const regex = /((\w*)([+-=]).*)(\2 \3.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\w*)([+-=]).*)(\\2 \\3.*)', 'gm')
const str = `a+2da + 2d
x-y=3x - y = 3
a+b-c=da + b - c = d
a_n=a+(n−1)da_n = a + (n - 1)d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}