re = /((\w*)([+-=]).*)(\2 \3.*)/m
str = 'a+2da + 2d
x-y=3x - y = 3
a+b-c=da + b - c = d
a_n=a+(n−1)da_n = a + (n - 1)d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end