#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?=.*<DuressAlarm>0</DuressAlarm>)(?=.*<PhoneIP>([^<]+)</PhoneIP>)"
Local $sString = "<?xml version='1.0' encoding='UTF-8' ?>" & @CRLF & _
"<SafeEvent>" & @CRLF & _
" <PhoneIP>192.168.0.119</PhoneIP>" & @CRLF & _
" <CellularIP></CellularIP>" & @CRLF & _
" <MACAddress>00907AB0300F</MACAddress>" & @CRLF & _
" <BSSID>fc:ec:da:b7:16:7a</BSSID>" & @CRLF & _
" <AlertType>Monitor</AlertType>" & @CRLF & _
" <StillAlarm>0</StillAlarm>" & @CRLF & _
" <TiltAlarm>0</TiltAlarm>" & @CRLF & _
" <RunningAlarm>0</RunningAlarm>" & @CRLF & _
" <DuressAlarm>0</DuressAlarm>" & @CRLF & _
" <TimeStamp>2022-02-14T00:24:08-0500</TimeStamp>" & @CRLF & _
" <LineNumber>0</LineNumber>" & @CRLF & _
" <Latitude>NA</Latitude>" & @CRLF & _
" <Longitude>NA</Longitude>" & @CRLF & _
"</SafeEvent>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")