const regex = new RegExp('(?=.*<DuressAlarm>0</DuressAlarm>)(?=.*<PhoneIP>([^<]+)</PhoneIP>)', 'gms')
const str = `<?xml version='1.0' encoding='UTF-8' ?>
<SafeEvent>
<PhoneIP>192.168.0.119</PhoneIP>
<CellularIP></CellularIP>
<MACAddress>00907AB0300F</MACAddress>
<BSSID>fc:ec:da:b7:16:7a</BSSID>
<AlertType>Monitor</AlertType>
<StillAlarm>0</StillAlarm>
<TiltAlarm>0</TiltAlarm>
<RunningAlarm>0</RunningAlarm>
<DuressAlarm>0</DuressAlarm>
<TimeStamp>2022-02-14T00:24:08-0500</TimeStamp>
<LineNumber>0</LineNumber>
<Latitude>NA</Latitude>
<Longitude>NA</Longitude>
</SafeEvent>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}