$re = '~(?=.*<DuressAlarm>0</DuressAlarm>)(?=.*<PhoneIP>([^<]+)</PhoneIP>)~ms';
$str = '<?xml version=\'1.0\' encoding=\'UTF-8\' ?>
<SafeEvent>
<PhoneIP>192.168.0.119</PhoneIP>
<CellularIP></CellularIP>
<MACAddress>00907AB0300F</MACAddress>
<BSSID>fc:ec:da:b7:16:7a</BSSID>
<AlertType>Monitor</AlertType>
<StillAlarm>0</StillAlarm>
<TiltAlarm>0</TiltAlarm>
<RunningAlarm>0</RunningAlarm>
<DuressAlarm>0</DuressAlarm>
<TimeStamp>2022-02-14T00:24:08-0500</TimeStamp>
<LineNumber>0</LineNumber>
<Latitude>NA</Latitude>
<Longitude>NA</Longitude>
</SafeEvent>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);