import Foundation
let pattern = #"(?=.*<DuressAlarm>0</DuressAlarm>)(?=.*<PhoneIP>([^<]+)</PhoneIP>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<?xml version='1.0' encoding='UTF-8' ?>
<SafeEvent>
<PhoneIP>192.168.0.119</PhoneIP>
<CellularIP></CellularIP>
<MACAddress>00907AB0300F</MACAddress>
<BSSID>fc:ec:da:b7:16:7a</BSSID>
<AlertType>Monitor</AlertType>
<StillAlarm>0</StillAlarm>
<TiltAlarm>0</TiltAlarm>
<RunningAlarm>0</RunningAlarm>
<DuressAlarm>0</DuressAlarm>
<TimeStamp>2022-02-14T00:24:08-0500</TimeStamp>
<LineNumber>0</LineNumber>
<Latitude>NA</Latitude>
<Longitude>NA</Longitude>
</SafeEvent>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)