import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*<DuressAlarm>0</DuressAlarm>)(?=.*<PhoneIP>([^<]+)</PhoneIP>)";
final String string = "<?xml version='1.0' encoding='UTF-8' ?>\n"
+ "<SafeEvent>\n"
+ " <PhoneIP>192.168.0.119</PhoneIP>\n"
+ " <CellularIP></CellularIP>\n"
+ " <MACAddress>00907AB0300F</MACAddress>\n"
+ " <BSSID>fc:ec:da:b7:16:7a</BSSID>\n"
+ " <AlertType>Monitor</AlertType>\n"
+ " <StillAlarm>0</StillAlarm>\n"
+ " <TiltAlarm>0</TiltAlarm>\n"
+ " <RunningAlarm>0</RunningAlarm>\n"
+ " <DuressAlarm>0</DuressAlarm>\n"
+ " <TimeStamp>2022-02-14T00:24:08-0500</TimeStamp>\n"
+ " <LineNumber>0</LineNumber>\n"
+ " <Latitude>NA</Latitude>\n"
+ " <Longitude>NA</Longitude>\n"
+ "</SafeEvent>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}