# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=.*<DuressAlarm>0</DuressAlarm>)(?=.*<PhoneIP>([^<]+)</PhoneIP>)"
test_str = ("<?xml version='1.0' encoding='UTF-8' ?>\n"
"<SafeEvent>\n"
" <PhoneIP>192.168.0.119</PhoneIP>\n"
" <CellularIP></CellularIP>\n"
" <MACAddress>00907AB0300F</MACAddress>\n"
" <BSSID>fc:ec:da:b7:16:7a</BSSID>\n"
" <AlertType>Monitor</AlertType>\n"
" <StillAlarm>0</StillAlarm>\n"
" <TiltAlarm>0</TiltAlarm>\n"
" <RunningAlarm>0</RunningAlarm>\n"
" <DuressAlarm>0</DuressAlarm>\n"
" <TimeStamp>2022-02-14T00:24:08-0500</TimeStamp>\n"
" <LineNumber>0</LineNumber>\n"
" <Latitude>NA</Latitude>\n"
" <Longitude>NA</Longitude>\n"
"</SafeEvent>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.