# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((['\"])(?:\\\2|(?!\2)[\w\W])*\2|\\/\*[\w\W]*?\*\\/)|\h*\\/\\/.*/\1/g;t' <<< "\"Testing a comment here // comment\" // comment
// comment
\"A bit \\" trickier yet \\" // comment\" // comment
// comment
// \"This should match since the comment came first\"
'Single \' quotes // comment' // comment
'''
Ignore
// comment
\''''
// comment
/*
multiline
// comment
*/"