#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((['\"])(?:\\\2|(?!\2)[\w\W])*\2|\/\*[\w\W]*?\*\/)|\h*\/\/.*"
Local $sString = ""Testing a comment here // comment" // comment" & @CRLF & _
"" & @CRLF & _
"// comment" & @CRLF & _
"" & @CRLF & _
""A bit \" trickier yet \" // comment" // comment" & @CRLF & _
"" & @CRLF & _
"// comment" & @CRLF & _
"" & @CRLF & _
"// "This should match since the comment came first"" & @CRLF & _
"" & @CRLF & _
"'Single \' quotes // comment' // comment" & @CRLF & _
"" & @CRLF & _
"'''" & @CRLF & _
"Ignore" & @CRLF & _
"// comment" & @CRLF & _
"\''''" & @CRLF & _
"" & @CRLF & _
"// comment" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"multiline" & @CRLF & _
"// comment" & @CRLF & _
"*/"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)