using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((['\""])(?:\\\2|(?!\2)[\w\W])*\2|\/\*[\w\W]*?\*\/)|\h*\/\/.*";
string substitution = @"\1";
string input = @"""Testing a comment here // comment"" // comment
// comment
""A bit \"" trickier yet \"" // comment"" // comment
// comment
// ""This should match since the comment came first""
'Single \' quotes // comment' // comment
'''
Ignore
// comment
\''''
// comment
/*
multiline
// comment
*/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}