use strict;
my $str = '"Testing a comment here // comment" // comment
// comment
"A bit \\" trickier yet \\" // comment" // comment
// comment
// "This should match since the comment came first"
\'Single \\\' quotes // comment\' // comment
\'\'\'
Ignore
// comment
\\\'\'\'\'
// comment
/*
multiline
// comment
*/';
my $regex = qr/((['\"])(?:\\\2|(?!\2)[\w\W])*\2|\/\*[\w\W]*?\*\/)|\h*\/\/.*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";