$re = '/(([\'\"])(?:\\\\\2|(?!\2)[\w\W])*\2|\/\*[\w\W]*?\*\/)|\h*\/\/.*/';
$str = '"Testing a comment here // comment" // comment
// comment
"A bit \\" trickier yet \\" // comment" // comment
// comment
// "This should match since the comment came first"
\'Single \\\' quotes // comment\' // comment
\'\'\'
Ignore
// comment
\\\'\'\'\'
// comment
/*
multiline
// comment
*/';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;