const regex = new RegExp('(([\\'\\"])(?:\\\\\\2|(?!\\2)[\\w\\W])*\\2|\\/\\*[\\w\\W]*?\\*\\/)|\\h*\\/\\/.*', 'g')
const str = `"Testing a comment here // comment" // comment
// comment
"A bit \\" trickier yet \\" // comment" // comment
// comment
// "This should match since the comment came first"
'Single \\' quotes // comment' // comment
'''
Ignore
// comment
\\''''
// comment
/*
multiline
// comment
*/`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);