$re = '/(?:^T|\G(?!^)).*?\Ke/m';
$str = 'The quick brown fox jumps over the lazy dog.
She opened the door.';
$subst = "3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;