import Foundation
let pattern = #"(?:^T|\G(?!^)).*?\Ke"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The quick brown fox jumps over the lazy dog.
She opened the door.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)