re = /(?:^T|\G(?!^)).*?\Ke/m
str = 'The quick brown fox jumps over the lazy dog.
She opened the door.'
subst = '3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result