import re
regex = re.compile(r"(?:^T|\G(?!^)).*?\Ke", flags=re.MULTILINE)
test_str = ("The quick brown fox jumps over the lazy dog.\n"
"She opened the door.")
subst = "3"
result = regex.sub(subst, test_str)
if result:
print(result)