use strict;
my $str = 'Home » Food » Fruit';
my $regex = qr/(»[^»]*)»/p;
my $subst = '$1Category:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";