$re = '/(»[^»]*)»/';
$str = 'Home » Food » Fruit';
$subst = "$1Category:";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;