import Foundation
let pattern = #"(»[^»]*)»"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Home » Food » Fruit"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1Category:"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)