using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Lead status\s*(\w.*)\R([^,]+),\s*([^,]*[^\s,])\s*.*(\d{5})$";
string input = @"Lead status
53 W 70th St
New York, New York 10023";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}