re = /Lead status\s*(\w.*)\R([^,]+),\s*([^,]*[^\s,])\s*.*(\d{5})$/m
str = 'Lead status
53 W 70th St
New York, New York 10023'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end