const regex = /Lead status\s*(\w.*)\R([^,]+),\s*([^,]*[^\s,])\s*.*(\d{5})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Lead status\\s*(\\w.*)\\R([^,]+),\\s*([^,]*[^\\s,])\\s*.*(\\d{5})$', 'gm')
const str = `Lead status
53 W 70th St
New York, New York 10023`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}