import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Lead status\\s*(\\w.*)\\R([^,]+),\\s*([^,]*[^\\s,])\\s*.*(\\d{5})$";
final String string = "Lead status\n\n"
+ "53 W 70th St\n"
+ "New York, New York 10023";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}