// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Lead status\s*(\w.*)\R([^,]+),\s*([^,]*[^\s,])\s*.*(\d{5})$").unwrap();
let string = "Lead status
53 W 70th St
New York, New York 10023";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}