#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^engine\.(.+)"
Local $sString = "engine.unreal-engine" & @CRLF & _
"engine.source2.arch" & @CRLF & _
"engine.source2.hollow-block" & @CRLF & _
"engine.source2.pivot-manipulation" & @CRLF & _
"engine.unreal-engine.best-practices" & @CRLF & _
"engine.unreal-engine.blueprint-interface" & @CRLF & _
"engine.unreal-engine.cpp-and-blueprints" & @CRLF & _
"engine.unreal-engine.directory" & @CRLF & _
"engine.unreal-engine.post-process-volume" & @CRLF & _
"lexicon.unreal-engine.actor" & @CRLF & _
"lexicon.unreal-engine.ai-controller" & @CRLF & _
"lexicon.unreal-engine.casting" & @CRLF & _
"lexicon.unreal-engine.character" & @CRLF & _
"lexicon.unreal-engine.component" & @CRLF & _
"lexicon.unreal-engine.pawn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")