use strict;
my $str = 'engine.unreal-engine
engine.source2.arch
engine.source2.hollow-block
engine.source2.pivot-manipulation
engine.unreal-engine.best-practices
engine.unreal-engine.blueprint-interface
engine.unreal-engine.cpp-and-blueprints
engine.unreal-engine.directory
engine.unreal-engine.post-process-volume
lexicon.unreal-engine.actor
lexicon.unreal-engine.ai-controller
lexicon.unreal-engine.casting
lexicon.unreal-engine.character
lexicon.unreal-engine.component
lexicon.unreal-engine.pawn';
my $regex = qr/^engine\.(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}